#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)Individual:\s*(.*?)\s(.*?)(?=\n|$)(?=.*\Buyer\b)"
Local $sString = "Seller(s):" & @CRLF & _
"Individual: MR John Smith" & @CRLF & _
"Individual: MR Jane Smith" & @CRLF & _
"Buyer(s):" & @CRLF & _
"Individual: MR Jack Jill"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")