const regex = /Individual:\s*(.*?)\s(.*?)(?=\n|$)(?=.*\Buyer\b)/smg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Individual:\\s*(.*?)\\s(.*?)(?=\\n|$)(?=.*\\Buyer\\b)', 'smg')
const str = `Seller(s):
Individual: MR John Smith
Individual: MR Jane Smith
Buyer(s):
Individual: MR Jack Jill`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}