$re = '/Individual:\s*(.*?)\s(.*?)(?=\n|$)(?=.*\Buyer\b)/sm';
$str = 'Seller(s):
Individual: MR John Smith
Individual: MR Jane Smith
Buyer(s):
Individual: MR Jack Jill';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);