using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Individual:\s*(.*?)\s(.*?)(?=\n|$)(?=.*\Buyer\b)";
string input = @"Seller(s):
Individual: MR John Smith
Individual: MR Jane Smith
Buyer(s):
Individual: MR Jack Jill";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}