import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Individual:\\s*(.*?)\\s(.*?)(?=\\n|$)(?=.*\\Buyer\\b)";
final String string = "Seller(s):\n"
+ "Individual: MR John Smith\n"
+ "Individual: MR Jane Smith\n"
+ "Buyer(s):\n"
+ "Individual: MR Jack Jill";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}