const regex = /\p{Sc}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\p{Sc}', 'g')
const str = `Vous pouvez payer en €uro en £ivre ou en ¥en. Et même en ₿itcoin !`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}