// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\p{Sc}").unwrap();
let string = "Vous pouvez payer en €uro en £ivre ou en ¥en. Et même en ₿itcoin !";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}