re = /\p{Sc}/
str = 'Vous pouvez payer en €uro en £ivre ou en ¥en. Et même en ₿itcoin !'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end