#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bi\b(?!.{0,7}not)[^.!?]{0,10}\bhate"
Local $sString = "" & @CRLF & _
"Now catches: " & @CRLF & _
"'i do not hate'." & @CRLF & _
"'i not hate'" & @CRLF & _
"" & @CRLF & _
"Would like to exclude that and leave only like" & @CRLF & _
"'i do hate' or" & @CRLF & _
"'i hate'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")