const regex = /\bi\b(?!.{0,7}not)[^.!?]{0,10}\bhate/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bi\\b(?!.{0,7}not)[^.!?]{0,10}\\bhate', 'g')
const str = `
Now catches:
'i do not hate'.
'i not hate'
Would like to exclude that and leave only like
'i do hate' or
'i hate'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}