import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bi\\b(?!.{0,7}not)[^.!?]{0,10}\\bhate";
final String string = "\n"
+ "Now catches: \n"
+ "'i do not hate'.\n"
+ "'i not hate'\n\n"
+ "Would like to exclude that and leave only like\n"
+ "'i do hate' or\n"
+ "'i hate'\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}