import Foundation
let pattern = #"\bi\b(?!.{0,7}not)[^.!?]{0,10}\bhate"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Now catches:
'i do not hate'.
'i not hate'
Would like to exclude that and leave only like
'i do hate' or
'i hate'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)