$re = '/\bi\b(?!.{0,7}not)[^.!?]{0,10}\bhate/';
$str = '
Now catches:
\'i do not hate\'.
\'i not hate\'
Would like to exclude that and leave only like
\'i do hate\' or
\'i hate\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);