const regex = /^(?!none@|na@)\w+(\.\w+)*@(\w+\.)+\w{2,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!none@|na@)\\w+(\\.\\w+)*@(\\w+\\.)+\\w{2,4}$', 'gm')
const str = `bob@bob.com
na@bob.com
none@bob.com
naa@bob.com
nonee@bob.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}