use strict;
my $str = 'bob@bob.com
na@bob.com
none@bob.com
naa@bob.com
nonee@bob.com';
my $regex = qr/^(?!none@|na@)\w+(\.\w+)*@(\w+\.)+\w{2,4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}