$re = '/^(?!none@|na@)\w+(\.\w+)*@(\w+\.)+\w{2,4}$/m';
$str = 'bob@bob.com
na@bob.com
none@bob.com
naa@bob.com
nonee@bob.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);