import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[\\d\\-\\/@#$]{12}\\b";
final String string = "18129561-000\n"
+ "asdf 1812956-1-000 asd\n"
+ "asdf 18129562-000 asd\n"
+ "asd18129561-000as\n"
+ "18129561@000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}