$re = '/\b[\d\-\/@#$]{12}\b/';
$str = '18129561-000
asdf 1812956-1-000 asd
asdf 18129562-000 asd
asd18129561-000as
18129561@000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);