import Foundation
let pattern = ##"\b[\d\-\/@#$]{12}\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
18129561-000
asdf 1812956-1-000 asd
asdf 18129562-000 asd
asd18129561-000as
18129561@000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)