re = /\b[\d\-\/@#$]{12}\b/
str = '18129561-000
asdf 1812956-1-000 asd
asdf 18129562-000 asd
asd18129561-000as
18129561@000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end