use strict;
my $str = '18129561-000
asdf 1812956-1-000 asd
asdf 18129562-000 asd
asd18129561-000as
18129561@000';
my $regex = qr/\b[\d\-\/@#$]{12}\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}