use strict;
my $str = '407/82 HAY STREET
A314/1 DEMETER STREET
51/14 HASSALL STREET
(LOT1022) 60 LACERTA ROAD
LOT1149 KELLY STREET
(LOT1003) KELLY STREET
(LOT1010) 65 ORION ROAD
(LOT1109) 80 LACERTA ROAD
(LOT1013) 59 ORION ROAD
(LOT1017) 28 MULUMULUNG STREET
(LOT1021) 62 LACERTA ROAD
A106/5 ADONIS AVENUE
C122/5 ADONIS AVENUE
17 DONCASTER STREET
E108/3 ADONIS AVENUE
103/46 WALKER STREET
C118/5 ADONIS AVENUE
13 GOODISON PARADE
305/6 BAY STREET
A507/18 O\'DEA AVENUE ';
my $regex = qr/^([A-Z0-9\/\(\)]*)\s?[0-9]*\s[A-Z\']*\s\b(ROAD|LANE|STREET|AVENUE|PARADE|WAY|DRIVE|HIGHWAY|PLACE)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}