$re = '/^([A-Z0-9\/\(\)]*)\s?[0-9]*\s[A-Z\']*\s\b(ROAD|LANE|STREET|AVENUE|PARADE|WAY|DRIVE|HIGHWAY|PLACE)\b/m';
$str = '407/82 HAY STREET
A314/1 DEMETER STREET
51/14 HASSALL STREET
(LOT1022) 60 LACERTA ROAD
LOT1149 KELLY STREET
(LOT1003) KELLY STREET
(LOT1010) 65 ORION ROAD
(LOT1109) 80 LACERTA ROAD
(LOT1013) 59 ORION ROAD
(LOT1017) 28 MULUMULUNG STREET
(LOT1021) 62 LACERTA ROAD
A106/5 ADONIS AVENUE
C122/5 ADONIS AVENUE
17 DONCASTER STREET
E108/3 ADONIS AVENUE
103/46 WALKER STREET
C118/5 ADONIS AVENUE
13 GOODISON PARADE
305/6 BAY STREET
A507/18 O\'DEA AVENUE ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);