#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((((?<feature>feature-[\w-~]+)\.)?((?<isAPI>api)\.)?)|((?<namespace>[\w-~]+)\.)|((?<noMatch>[\w-~\.]+)\.)))?(?<domain>\w+\.\w+)$"
Local $sString = "domain.tld" & @CRLF & _
"subdomain.domain.tld" & @CRLF & _
"api.domain.tld" & @CRLF & _
"feature-test-1234.domain.tld" & @CRLF & _
"feature-test~1234_dwedq.api.domain.tld" & @CRLF & _
"test-1234.subdomain.api.domain.tld" & @CRLF & _
"test-1234.subdomain.domain.tld"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")