re = /^(((((?<feature>feature-[\w-~]+)\.)?((?<isAPI>api)\.)?)|((?<namespace>[\w-~]+)\.)|((?<noMatch>[\w-~\.]+)\.)))?(?<domain>\w+\.\w+)$/m
str = 'domain.tld
subdomain.domain.tld
api.domain.tld
feature-test-1234.domain.tld
feature-test~1234_dwedq.api.domain.tld
test-1234.subdomain.api.domain.tld
test-1234.subdomain.domain.tld'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end