// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((((?<feature>feature-[\w-~]+)\.)?((?<isAPI>api)\.)?)|((?<namespace>[\w-~]+)\.)|((?<noMatch>[\w-~\.]+)\.)))?(?<domain>\w+\.\w+)$").unwrap();
let string = "domain.tld
subdomain.domain.tld
api.domain.tld
feature-test-1234.domain.tld
feature-test~1234_dwedq.api.domain.tld
test-1234.subdomain.api.domain.tld
test-1234.subdomain.domain.tld";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}