const regex = /^(((((?<feature>feature-[\w-~]+)\.)?((?<isAPI>api)\.)?)|((?<namespace>[\w-~]+)\.)|((?<noMatch>[\w-~\.]+)\.)))?(?<domain>\w+\.\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((((?<feature>feature-[\\w-~]+)\\.)?((?<isAPI>api)\\.)?)|((?<namespace>[\\w-~]+)\\.)|((?<noMatch>[\\w-~\\.]+)\\.)))?(?<domain>\\w+\\.\\w+)$', 'gm')
const str = `domain.tld
subdomain.domain.tld
api.domain.tld
feature-test-1234.domain.tld
feature-test~1234_dwedq.api.domain.tld
test-1234.subdomain.api.domain.tld
test-1234.subdomain.domain.tld`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}