using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CREATE TABLE \x60(\w*)\x60 \(\n(.*?)^\) (.*?);";
string input = @"# ------------------------------------------------------------
CREATE TABLE `bkash_agent_incentive_status` (
`wallet_number` varchar(15) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL,
`status` int(11) NOT NULL,
`comment` longtext,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
PRIMARY KEY (`wallet_number`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
# Dump of table bkash_barcodes
# ------------------------------------------------------------
CREATE TABLE `bkash_barcodes` (
`barcode_number` varchar(25) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL,
`registered` tinyint(1) DEFAULT NULL,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
`created_email` varchar(50) DEFAULT NULL,
PRIMARY KEY (`barcode_number`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}