import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CREATE TABLE \\x60(\\w*)\\x60 \\(\\n(.*?)^\\) (.*?);";
final String string = "# ------------------------------------------------------------\n\n"
+ "CREATE TABLE `bkash_agent_incentive_status` (\n"
+ " `wallet_number` varchar(15) NOT NULL,\n"
+ " `created_by` bigint(20) DEFAULT NULL,\n"
+ " `updated_by` bigint(20) DEFAULT NULL,\n"
+ " `deleted_by` bigint(20) DEFAULT NULL,\n"
+ " `status` int(11) NOT NULL,\n"
+ " `comment` longtext,\n"
+ " `createdAt` datetime DEFAULT NULL,\n"
+ " `updatedAt` datetime DEFAULT NULL,\n"
+ " PRIMARY KEY (`wallet_number`)\n"
+ ") ENGINE=InnoDB DEFAULT CHARSET=utf8;\n\n\n\n"
+ "# Dump of table bkash_barcodes\n"
+ "# ------------------------------------------------------------\n\n"
+ "CREATE TABLE `bkash_barcodes` (\n"
+ " `barcode_number` varchar(25) NOT NULL,\n"
+ " `created_by` bigint(20) DEFAULT NULL,\n"
+ " `updated_by` bigint(20) DEFAULT NULL,\n"
+ " `deleted_by` bigint(20) DEFAULT NULL,\n"
+ " `registered` tinyint(1) DEFAULT NULL,\n"
+ " `createdAt` datetime DEFAULT NULL,\n"
+ " `updatedAt` datetime DEFAULT NULL,\n"
+ " `created_email` varchar(50) DEFAULT NULL,\n"
+ " PRIMARY KEY (`barcode_number`)\n"
+ ") ENGINE=InnoDB DEFAULT CHARSET=utf8;\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}