const regex = new RegExp('CREATE TABLE \\x60(\\w*)\\x60 \\(\\n(.*?)^\\) (.*?);', 'gms')
const str = `# ------------------------------------------------------------
CREATE TABLE \`bkash_agent_incentive_status\` (
\`wallet_number\` varchar(15) NOT NULL,
\`created_by\` bigint(20) DEFAULT NULL,
\`updated_by\` bigint(20) DEFAULT NULL,
\`deleted_by\` bigint(20) DEFAULT NULL,
\`status\` int(11) NOT NULL,
\`comment\` longtext,
\`createdAt\` datetime DEFAULT NULL,
\`updatedAt\` datetime DEFAULT NULL,
PRIMARY KEY (\`wallet_number\`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
# Dump of table bkash_barcodes
# ------------------------------------------------------------
CREATE TABLE \`bkash_barcodes\` (
\`barcode_number\` varchar(25) NOT NULL,
\`created_by\` bigint(20) DEFAULT NULL,
\`updated_by\` bigint(20) DEFAULT NULL,
\`deleted_by\` bigint(20) DEFAULT NULL,
\`registered\` tinyint(1) DEFAULT NULL,
\`createdAt\` datetime DEFAULT NULL,
\`updatedAt\` datetime DEFAULT NULL,
\`created_email\` varchar(50) DEFAULT NULL,
PRIMARY KEY (\`barcode_number\`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}