import Foundation
let pattern = #"CREATE TABLE \x60(\w*)\x60 \(\n(.*?)^\) (.*?);"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
# ------------------------------------------------------------
CREATE TABLE `bkash_agent_incentive_status` (
`wallet_number` varchar(15) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL,
`status` int(11) NOT NULL,
`comment` longtext,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
PRIMARY KEY (`wallet_number`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
# Dump of table bkash_barcodes
# ------------------------------------------------------------
CREATE TABLE `bkash_barcodes` (
`barcode_number` varchar(25) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL,
`registered` tinyint(1) DEFAULT NULL,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
`created_email` varchar(50) DEFAULT NULL,
PRIMARY KEY (`barcode_number`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)