re = /CREATE TABLE \x60(\w*)\x60 \(\n(.*?)^\) (.*?);/m
str = '# ------------------------------------------------------------
CREATE TABLE `bkash_agent_incentive_status` (
`wallet_number` varchar(15) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL,
`status` int(11) NOT NULL,
`comment` longtext,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
PRIMARY KEY (`wallet_number`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
# Dump of table bkash_barcodes
# ------------------------------------------------------------
CREATE TABLE `bkash_barcodes` (
`barcode_number` varchar(25) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL,
`registered` tinyint(1) DEFAULT NULL,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
`created_email` varchar(50) DEFAULT NULL,
PRIMARY KEY (`barcode_number`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end