#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(?=\S)(?!\/\*\*)(?!\/\/)(?!\*).*(\\?)JText"
Local $sString = "<button aria-label="<?php echo JText::_('JCANCEL'); ?>">" & @CRLF & _
"" & @CRLF & _
"// JText" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * Comment block" & @CRLF & _
" * ------------------" & @CRLF & _
" * @param JText" & @CRLF & _
" *" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")