import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?=\\S)(?!\\/\\*\\*)(?!\\/\\/)(?!\\*).*(\\\\?)JText";
final String string = "<button aria-label=\"<?php echo JText::_('JCANCEL'); ?>\">\n\n"
+ "// JText\n\n"
+ "/**\n"
+ " * Comment block\n"
+ " * ------------------\n"
+ " * @param JText\n"
+ " *\n"
+ " */";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}