using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?=\S)(?!\/\*\*)(?!\/\/)(?!\*).*(\\?)JText";
string input = @"<button aria-label=""<?php echo JText::_('JCANCEL'); ?>"">
// JText
/**
* Comment block
* ------------------
* @param JText
*
*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}