re = /^\s*(?=\S)(?!\/\*\*)(?!\/\/)(?!\*).*(\\?)JText/m
str = '<button aria-label="<?php echo JText::_(\'JCANCEL\'); ?>">
// JText
/**
* Comment block
* ------------------
* @param JText
*
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end