$re = '/^\s*(?=\S)(?!\/\*\*)(?!\/\/)(?!\*).*(\\\\?)JText/m';
$str = '<button aria-label="<?php echo JText::_(\'JCANCEL\'); ?>">
// JText
/**
* Comment block
* ------------------
* @param JText
*
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);