using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\D+)(\d+)(\D)(\d+)";
string input = @"V230630C00200000
COIN230630C00020000
TSLA230818P00025000
SPXS230630C00019000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}