re = /(\D+)(\d+)(\D)(\d+)/m
str = 'V230630C00200000
COIN230630C00020000
TSLA230818P00025000
SPXS230630C00019000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end