// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\D+)(\d+)(\D)(\d+)").unwrap();
let string = "V230630C00200000
COIN230630C00020000
TSLA230818P00025000
SPXS230630C00019000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}