$re = '/(\D+)(\d+)(\D)(\d+)/m';
$str = 'V230630C00200000
COIN230630C00020000
TSLA230818P00025000
SPXS230630C00019000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);