package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\D+)(\d+)(\D)(\d+)`)
var str = `V230630C00200000
COIN230630C00020000
TSLA230818P00025000
SPXS230630C00019000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}