const regex = /\"(?<job_ids>(?:\w+-\w+-\w+-\w+-\w+)+),?\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"(?<job_ids>(?:\\w+-\\w+-\\w+-\\w+-\\w+)+),?\\"', 'gm')
const str = `{"JobIds":["661ce07c-b5f3-4b37-8b4c-a0b76d890039","db7a18ae-ea59-4987-87d5-c80adefa4475"]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}