$re = '/\"(?<job_ids>(?:\w+-\w+-\w+-\w+-\w+)+),?\"/m';
$str = '{"JobIds":["661ce07c-b5f3-4b37-8b4c-a0b76d890039","db7a18ae-ea59-4987-87d5-c80adefa4475"]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);