import re
regex = re.compile(r"\"(?<job_ids>(?:\w+-\w+-\w+-\w+-\w+)+),?\"", flags=re.MULTILINE)
test_str = "{\"JobIds\":[\"661ce07c-b5f3-4b37-8b4c-a0b76d890039\",\"db7a18ae-ea59-4987-87d5-c80adefa4475\"]}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")