// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"(?<job_ids>(?:\w+-\w+-\w+-\w+-\w+)+),?\""#).unwrap();
let string = "{\"JobIds\":[\"661ce07c-b5f3-4b37-8b4c-a0b76d890039\",\"db7a18ae-ea59-4987-87d5-c80adefa4475\"]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}