using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([^,\n]*),){3}([^\n]+)";
string substitution = @"$1:$2";
string input = @"null,admin,abc@site.ru,123
null,admin,cde@site.ru,345
,joe,efg@site.ru,333
,bob,ghj@site.ru,444
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}