$re = '~^(?:([^,\n]*),){3}([^\n]+)~m';
$str = 'null,admin,abc@site.ru,123
null,admin,cde@site.ru,345
,joe,efg@site.ru,333
,bob,ghj@site.ru,444
';
$subst = "$1:$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;