package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([^,\n]*),){3}([^\n]+)`)
var str = `null,admin,abc@site.ru,123
null,admin,cde@site.ru,345
,joe,efg@site.ru,333
,bob,ghj@site.ru,444
`
var substitution = "$1:$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}