const regex = new RegExp('^(?:([^,\\n]*),){3}([^\\n]+)', 'gm')
const str = `null,admin,abc@site.ru,123
null,admin,cde@site.ru,345
,joe,efg@site.ru,333
,bob,ghj@site.ru,444
`;
const subst = `$1:$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);